$re = '/^[^ \']((\d+\pL+[\']?|\pL+\d+|\pL+[\']?\d+|\d+[ ]?\pL+[\']?|\pL+[\']?)[ ]?)+$/u';
$str = '11ffff\' hh\'h777 hjhh\'6565 666 gggg rrt\'rt';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);