using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(My Search String)\s*\:\s*\{(?<myJson>[^\}]+)\}";
string input = @"My Search String : {""key1"":""value1"",""key2"":""value2""}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}