re = /(My Search String)\s*\:\s*\{(?<myJson>[^\}]+)\}/
str = 'My Search String : {"key1":"value1","key2":"value2"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end