#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?x)" & @CRLF & _
" ^\s*" & @CRLF & _
" (" & @CRLF & _
" <\/(cf)[A-Za-z0-9]+\b[^>]*>" & @CRLF & _
" |-?-->" & @CRLF & _
" |<cfelseif\b[^>]*>" & @CRLF & _
"|<cfelse\b[^>]*>" & @CRLF & _
" )"
Local $sString = "<cfif >" & @CRLF & _
"<cfoutput>" & @CRLF & _
"aaaaaaa" & @CRLF & _
"</cfoutput>" & @CRLF & _
"<!---" & @CRLF & _
"--->" & @CRLF & _
"<cfelse>" & @CRLF & _
"<cfelseif a eq b>" & @CRLF & _
"<cfset a =b />" & @CRLF & _
"<cfset a =b>" & @CRLF & _
"</cfif>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")