package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)x.*z`)
var str = `xaz xazx xaxsza zsxdaszdx zasxz xaaz xaaaz`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}