re = /([a-z0-9,!#\$%&\*\+=\?\^_`\{\|}~-]+(\.[a-z0-9,!#\$%&\*\+=\?\^_`\{\|}~-]+)*@[a-z0-9-]+(\.[a-z0-9-]+)*\.(?>[a-z]{2,})[ ]?):(.*)/m
str = 'test@test.ru:123
test@test.ru:1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end