using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z.0-9\n!)(]*(\s[&|]\s)";
string input = @"permission.test1 & permission.test2
permission.test1 | permission.test2
permission.test1 | !permission.test2
permission.test1 | (permission.test2 & permission.test3)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}