re = /[a-zA-Z.0-9\n!)(]*(\s[&|]\s)/
str = 'permission.test1 & permission.test2
permission.test1 | permission.test2
permission.test1 | !permission.test2
permission.test1 | (permission.test2 & permission.test3)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end