re = /^[A-Za-z!#\$%&'\*\+\-\/=\?\^_`{\|}~åäöÅÄÖ]+[A-Za-z!#\$%&'\*\+\-\/=\?\^_`{\|}~åäöÅÄÖ\.]*[A-Za-z!#\$%&'\*\+\-\/=\?\^_`{\|}~åäöÅÄÖ]+@[A-Za-zÅÄÖåäö]+\.[A-Za-z]*$/
str = 'ivar.matstoms@gmail.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end