$re = '~<(\w+)[^>]*>[\p{Z}\p{C}]*</\1>~u';
$str = '<strong class="a b"></strong><strong class="a b"><br class="a b" /></strong><strong class="a b">ï »¿ï»¿</strong><br class="a b" /><strong class="a b"><br class="a b" /><br class="a b" /></strong>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);