using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(C|In|S|Cu|Se)(?=[A-Z0-9]|$|\s)";
string input = @"CuIn2Se";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}