$re = '/(C|In|S|Cu|Se)(?=[A-Z0-9]|$|\s)/';
$str = 'CuIn2Se';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);