const regex = /$_COOKIE/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('$_COOKIE', 'gm')
const str = `\$_COOKIE[idlogin]`;
const subst = `asdas`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);