$re = '/$_COOKIE/m';
$str = '$_COOKIE[idlogin]';
$subst = "asdas";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;