using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^dividend paid((?!non).)*$";
string input = @"Dividend paid by the Company
Dividend paid by a subsidiary to non-controlling interests
Dividend paid";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}