$re = '/^dividend paid((?!non).)*$/mi';
$str = 'Dividend paid by the Company
Dividend paid by a subsidiary to non-controlling interests
Dividend paid';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);