#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?=.*spe*d).*engine.*"
Local $sString = "Spd_Engine #Ok" & @CRLF & _
"speedengine #Ok" & @CRLF & _
"enginespd #Ok" & @CRLF & _
"Engine_speed #Ok" & @CRLF & _
"aps_speed_engine #Ok" & @CRLF & _
"engine_speed #Ok" & @CRLF & _
"engine_trq #Not Ok" & @CRLF & _
"speed_rpm #Not Ok" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")