re = /^(?=.*spe*d).*engine.*/im
str = 'Spd_Engine #Ok
speedengine #Ok
enginespd #Ok
Engine_speed #Ok
aps_speed_engine #Ok
engine_speed #Ok
engine_trq #Not Ok
speed_rpm #Not Ok
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end