const regex = /'\w+:\w+'/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'\\w+:\\w+\'', 'g')
const str = `test1:testVar('varName', 'ns2:test')
test2:testVar('varName', 'ns2:test', 'defValue')
String t3 = "test2:testVar('varName', 'ns2:test', 'defValue') = test2:testVar('varName', 'ns1:test111', 'defValue') ";`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}