// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"'\w+:\w+'").unwrap();
let string = "test1:testVar('varName', 'ns2:test')
test2:testVar('varName', 'ns2:test', 'defValue')
String t3 = \"test2:testVar('varName', 'ns2:test', 'defValue') = test2:testVar('varName', 'ns1:test111', 'defValue') \";";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}