package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\t|^)"[^"]+"`)
var str = `a "b c" d "e f" "a b" "a b"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}