package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https?://\S+)`)
var str = `Good Day,I would like to $1000 (for example remove these parenthesis) $test $ asdf [and remove these brackets] inquire the price of the 3D product name here. Currently we have the other product name here which I believe has an accuracy of about 0.0005 199 200. http://www.example.com this is a test`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}