re = /(https?:\/\/\S+)/
str = 'Good Day,I would like to $1000 (for example remove these parenthesis) $test $ asdf [and remove these brackets] inquire the price of the 3D product name here. Currently we have the other product name here which I believe has an accuracy of about 0.0005 199 200. http://www.example.com this is a test'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result