using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<fromall>(?P<form>\/[A-z]+)(?<formid>\(.*?\))|\/[A-z]+)(?=.*\?\$select)";
string input = @"/Instellingen/Instellingen/Instellingen(123)/Instellingen(ddsf)?$select=Instelling_SK123ID,/Instellingen,Brin,Instellingsnaam,SoortInstelling,Website,Telefoon,Email,Vestigingen/*&$expand=V
YEAH DEZE:
(?P<fromall>(?P<form>\/[A-z]+)(?<formid>\(.*?\))|\/[A-z]+)(?=.*\?\$select)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}