re = /(?P<fromall>(?P<form>\/[A-z]+)(?<formid>\(.*?\))|\/[A-z]+)(?=.*\?\$select)/m
str = '/Instellingen/Instellingen/Instellingen(123)/Instellingen(ddsf)?$select=Instelling_SK123ID,/Instellingen,Brin,Instellingsnaam,SoortInstelling,Website,Telefoon,Email,Vestigingen/*&$expand=V
YEAH DEZE:
(?P<fromall>(?P<form>\\/[A-z]+)(?<formid>\\(.*?\\))|\\/[A-z]+)(?=.*\\?\\$select)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end