package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)".*?"`)
var str = `1,2,"toto , titi",3"titi ,, tata",4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}