$re = '/".*?"/m';
$str = '1,2,"toto , titi",3"titi ,, tata",4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);