$re = '/(?<!["])(")\w+/m';
$str = 'hi my name is "ma35x4" //i wants to match the word ma35x4 without any "';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);