re = /(?<!["])(")\w+/m
str = 'hi my name is "ma35x4" //i wants to match the word ma35x4 without any "'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end