import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span.*data-.*=\"(.+\\n.+\\n.+\\n.+\\n.+)\".*";
final String string = "<span data-clipboard-text=\"advocaciamdc.com\n"
+ "adunsg.com\n"
+ "adogstails.com\n"
+ "AdmissionZilla.com\n"
+ "AcehReseller.com\"></span>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}