re = /<span.*data-.*="(.+\n.+\n.+\n.+\n.+)".*/m
str = '<span data-clipboard-text="advocaciamdc.com
adunsg.com
adogstails.com
AdmissionZilla.com
AcehReseller.com"></span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end