package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+(?:\.\d+)?,\d+`)
var str = `|C195|1|Base de Cálculo ST: 2.608,24 - Valor da ST: 163,66|`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}