re = /\d+(?:\.\d+)?,\d+/
str = '|C195|1|Base de Cálculo ST: 2.608,24 - Valor da ST: 163,66|'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end