const regex = /(\bKEYWORD|(?!^)\G).*?\KSEARCHWORD/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\bKEYWORD|(?!^)\\G).*?\\KSEARCHWORD', 'gs')
const str = `Lorem ipsum dolor SEARCHWORD sit amet, consectetur adipiscing elit. Fusce lacus nisl, feugiat laoreet dignissim sit amet, KEYWORD gravida vel velit. Nunc SEARCHWORD elementum risus orci, ac tristique sem fringilla SEARCHWORD eget. Morbi maximus lectus nulla, sed tempor nibh SEARCHWORD condimentum ut. Sed tincidunt cursus nibh`;
const subst = `<b>SEARCHWORD</b>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);