import re
regex = re.compile(r"(\bKEYWORD|(?!^)\G).*?\KSEARCHWORD", flags=re.DOTALL)
test_str = "Lorem ipsum dolor SEARCHWORD sit amet, consectetur adipiscing elit. Fusce lacus nisl, feugiat laoreet dignissim sit amet, KEYWORD gravida vel velit. Nunc SEARCHWORD elementum risus orci, ac tristique sem fringilla SEARCHWORD eget. Morbi maximus lectus nulla, sed tempor nibh SEARCHWORD condimentum ut. Sed tincidunt cursus nibh"
subst = "<b>SEARCHWORD</b>"
result = regex.sub(subst, test_str)
if result:
print(result)