#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d+)\..*"
Local $sString = "50.000"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)