use strict;
my $str = '50.000';
my $regex = qr/(\d+)\..*/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";