package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*>+.*?(\n|$)`)
var str = `Good Text
> Text...
>
> More random text.
Good Text
> More Text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}