$re = '/^\s*>+.*?(\n|$)/m';
$str = 'Good Text
> Text...
>
> More random text.
Good Text
> More Text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);