package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(file_exists|is_file)\(([^)]+)`)
var str = `if (is_file($file)){
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}