$re = '/^\s*(https?|ftp|mailto|tel|file):.*(?!\.(js|html))$/m';
$str = 'http://www.foo.js
http://foo.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);