re = /^\s*(https?|ftp|mailto|tel|file):.*(?!\.(js|html))$/m
str = 'http://www.foo.js
http://foo.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end