using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)(?=(?:(?!\().)*\))";
string input = @"1 (2) 3 (4 5) 6 (7 8 9) 0
1(2)3(4 5)6(7 8 9)0";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}