re = /(\d+)(?=(?:(?!\().)*\))/
str = '1 (2) 3 (4 5) 6 (7 8 9) 0
1(2)3(4 5)6(7 8 9)0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end