import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i).+FE00(.{20}).+";
final String string = "0x00FFFFFFFFFFFF000DAF21170000000005130103802716780A06359E56529829145054000000010101010101010101010101010101012F2640A060841A30302035007ED710000018000000FE004E3137334647452D4C32310A20000000FE00434D4F0A202020202020202020000000FE004E3137334647452D4C32310A2000C3";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}