#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m),{0,1} \w+.(\w+), \w+.(\w+)"
Local $sString = " v1.VAC_ID, v2.VAC_ID" & @CRLF & _
", v1.PAC_ID, v2.PAC_ID" & @CRLF & _
", v1.ICL_CPI, v2.ICL_CPI" & @CRLF & _
", v1.VAC_TVA, v2.VAC_TVA" & @CRLF & _
", v1.TVA_SID, v2.TVA_SID" & @CRLF & _
", v1.VAC_DAD, v2.VAC_DAD" & @CRLF & _
", v1.VAC_DAD_A, v2.VAC_DAD_A" & @CRLF & _
", v1.VAC_DAD_M, v2.VAC_DAD_M" & @CRLF & _
", v1.VAC_DAD_H, v2.VAC_DAD_H" & @CRLF & _
", v1.VAC_DOS, v2.VAC_DOS" & @CRLF & _
", v1.VAC_CPV, v2.VAC_CPV" & @CRLF & _
", v1.VAC_TAC, v2.VAC_TAC" & @CRLF & _
", v1.VAC_OIN, v2.VAC_OIN" & @CRLF & _
", v1.PRO_ID, v2.PRO_ID" & @CRLF & _
", v1.RCV_ID, v2.RCV_ID" & @CRLF & _
", v1.ID_HORA, v2.ID_HORA" & @CRLF & _
", v1.COUNT, v2.COUNT" & @CRLF & _
", v1.ASS_SEXE, v2.ASS_SEXE" & @CRLF & _
", v1.ASS_DNA, v2.ASS_DNA" & @CRLF & _
", v1.ASS_DNA_A, v2.ASS_DNA_A" & @CRLF & _
", v1.EDAT, v2.EDAT" & @CRLF & _
", v1.UPR_CUP, v2.UPR_CUP" & @CRLF & _
", v1.UPR_CUP_T, v2.UPR_CUP_T" & @CRLF & _
", v1.PAC_NIA, v2.PAC_NIA" & @CRLF & _
", v1.ASS_CSA, v2.ASS_CSA" & @CRLF & _
", v1.ICL_UP, v2.ICL_UP" & @CRLF & _
", v1.ICL_BAC, v2.ICL_BAC" & @CRLF & _
", v1.ICP_UP_ORIGINAL, v2.ICP_UP_ORIGINAL" & @CRLF & _
", v1.VAC_DED, v2.VAC_DED" & @CRLF & _
", v1.VAC_DED_TRUNC, v2.VAC_DED_TRUNC" & @CRLF & _
", v1.ICL_BAD, v2.ICL_BAD" & @CRLF & _
", v1.ICL_BAD_TRUNC, v2.ICL_BAD_TRUNC" & @CRLF & _
", v1.COUNT_ACTIUS, v2.COUNT_ACTIUS" & @CRLF & _
", v1.VAC_LOT, v2.VAC_LOT" & @CRLF & _
", v1.VAC_VIA, v2.VAC_VIA" & @CRLF & _
", v1.VAC_DCV, v2.VAC_DCV" & @CRLF & _
", v1.VAC_LAD, v2.VAC_LAD" & @CRLF & _
", v1.VAC_MNV, v2.VAC_MNV" & @CRLF & _
", v1.VAC_GPE, v2.VAC_GPE" & @CRLF & _
", v1.VAC_GPV, v2.VAC_GPV" & @CRLF & _
", v1.VAC_MCO, v2.VAC_MCO" & @CRLF & _
", v1.TSI_LOCALITAT, v2.TSI_LOCALITAT" & @CRLF & _
", v1.TSI_CPOSTAL, v2.TSI_CPOSTAL" & @CRLF & _
", v1.PAC_CIP, v2.PAC_CIP" & @CRLF & _
", v1.VAC_DAD_TRUNC, v2.VAC_DAD_TRUNC"
Local $sSubst = "or decode(v1.$1, v2.$2, 1, 0) = 0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)