import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",{0,1} \\w+.(\\w+), \\w+.(\\w+)";
final String string = " v1.VAC_ID, v2.VAC_ID\n"
+ ", v1.PAC_ID, v2.PAC_ID\n"
+ ", v1.ICL_CPI, v2.ICL_CPI\n"
+ ", v1.VAC_TVA, v2.VAC_TVA\n"
+ ", v1.TVA_SID, v2.TVA_SID\n"
+ ", v1.VAC_DAD, v2.VAC_DAD\n"
+ ", v1.VAC_DAD_A, v2.VAC_DAD_A\n"
+ ", v1.VAC_DAD_M, v2.VAC_DAD_M\n"
+ ", v1.VAC_DAD_H, v2.VAC_DAD_H\n"
+ ", v1.VAC_DOS, v2.VAC_DOS\n"
+ ", v1.VAC_CPV, v2.VAC_CPV\n"
+ ", v1.VAC_TAC, v2.VAC_TAC\n"
+ ", v1.VAC_OIN, v2.VAC_OIN\n"
+ ", v1.PRO_ID, v2.PRO_ID\n"
+ ", v1.RCV_ID, v2.RCV_ID\n"
+ ", v1.ID_HORA, v2.ID_HORA\n"
+ ", v1.COUNT, v2.COUNT\n"
+ ", v1.ASS_SEXE, v2.ASS_SEXE\n"
+ ", v1.ASS_DNA, v2.ASS_DNA\n"
+ ", v1.ASS_DNA_A, v2.ASS_DNA_A\n"
+ ", v1.EDAT, v2.EDAT\n"
+ ", v1.UPR_CUP, v2.UPR_CUP\n"
+ ", v1.UPR_CUP_T, v2.UPR_CUP_T\n"
+ ", v1.PAC_NIA, v2.PAC_NIA\n"
+ ", v1.ASS_CSA, v2.ASS_CSA\n"
+ ", v1.ICL_UP, v2.ICL_UP\n"
+ ", v1.ICL_BAC, v2.ICL_BAC\n"
+ ", v1.ICP_UP_ORIGINAL, v2.ICP_UP_ORIGINAL\n"
+ ", v1.VAC_DED, v2.VAC_DED\n"
+ ", v1.VAC_DED_TRUNC, v2.VAC_DED_TRUNC\n"
+ ", v1.ICL_BAD, v2.ICL_BAD\n"
+ ", v1.ICL_BAD_TRUNC, v2.ICL_BAD_TRUNC\n"
+ ", v1.COUNT_ACTIUS, v2.COUNT_ACTIUS\n"
+ ", v1.VAC_LOT, v2.VAC_LOT\n"
+ ", v1.VAC_VIA, v2.VAC_VIA\n"
+ ", v1.VAC_DCV, v2.VAC_DCV\n"
+ ", v1.VAC_LAD, v2.VAC_LAD\n"
+ ", v1.VAC_MNV, v2.VAC_MNV\n"
+ ", v1.VAC_GPE, v2.VAC_GPE\n"
+ ", v1.VAC_GPV, v2.VAC_GPV\n"
+ ", v1.VAC_MCO, v2.VAC_MCO\n"
+ ", v1.TSI_LOCALITAT, v2.TSI_LOCALITAT\n"
+ ", v1.TSI_CPOSTAL, v2.TSI_CPOSTAL\n"
+ ", v1.PAC_CIP, v2.PAC_CIP\n"
+ ", v1.VAC_DAD_TRUNC, v2.VAC_DAD_TRUNC";
final String subst = "or decode(v1.$1, v2.$2, 1, 0) = 0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}