#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:.+) )?love( (?:.+))?!"
Local $sString = "love!" & @CRLF & _
"" & @CRLF & _
"i love!" & @CRLF & _
"" & @CRLF & _
"love you!" & @CRLF & _
"" & @CRLF & _
"i love you!" & @CRLF & _
"" & @CRLF & _
"love" & @CRLF & _
"ilove you" & @CRLF & _
"i loveyou" & @CRLF & _
"iloveyou"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")