package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:.+) )?love( (?:.+))?!`)
var str = `love!
i love!
love you!
i love you!
love
ilove you
i loveyou
iloveyou`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}