$re = '/(?:Xander.*\bcar\b|\bcar\b.*Xander)/mU';
$str = 'I’m looking for, but don’t know whether I am looking for “Xander’s car” ,“Xander got into the car”, “Xander leapt out of the way of the car”, or some other possibility.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);